Firefox: "Installation completed" or app screen appears when trying to connect to a session

Support Center > Troubleshooting Connection Issues

Published 08/15/2014 at 9:56pm UTC

Page viewed 41851 times

Symptom

Firefox's program settings may be the source of your issue if

  • You can join sessions in browsers other than Firefox.
  • You have successfully downloaded and installed our video app, Zoom. (If you haven't or are not sure, see this article.) 

 

If Firefox is trying to launch the session with the Zoom install file instead of the program file, it will just install the video app again instead of connecting to your session.

 

 

If you or your host are using our Zoom app, you may see the following: 

Zoom splash screen

 

 

 

 

 

 

Possible Causes

When you attempt to enter a waiting room or join a participant to a session, SecureVideo launches our videoconferencing application for you. If you're using Firefox, it will ask you to confirm which program you wish to launch. See the image below for an example. 

 Screencap showing Chrome's External Protocol Request

If you click the available "Zoom Meetings" and you click Open link, Firefox will allow you to proceed.

 

However, if you click "Choose other Application" to search for another file and try to use that (such as the video app installation file), the launch will fail, and Firefox will try to use that path each time in the future. This will prevent from using Firefox for your SecureVideo sessions, unless you reset your program settings as detailed below. 

 

 

Note: if you did not see "Zoom Meetings" automatically shown by Firefox, it means that Zoom is not installed on your computer. You will need to install it. 

 

Resolution

 

 

Firefox version 91 or later

1. Click on Firefox's Menu icon, and then click on the Settings option. 

  • On a Mac, this option is called Preferences.

Screencap showing the menu icon and "Settings" option

 

 

2. Scroll down until you see the Applications section. In the search field, enter "zoom".

 

3. In the "Action" column, click on the little triangle on the right-hand side. Select "Use Zoom Meetings (default)" from the drop-down menu.

Application handling preferences

 

 

4. It should save automatically. Return to your dashboard or the waiting room page, and click to enter the meeting again. 

 

 

Firefox version 57 or later (Firefox Quantum)

1. Click on Firefox's Menu icon, and then click on the Options option. 

  • On a Mac, this option is called Preferences.

Screencap showing the menu icon and "Options" option

 

 

2. Scroll down until you see the Applications section. In the search field, enter "zoom".

 

3. In the "Action" column, click on the little triangle on the right-hand side. Select "Use Zoom Meetings (default)" from the drop-down menu.

Application handling preferences

 

 

4. It should save automatically. Return to your dashboard or the waiting room page, and click to enter the meeting again. 

 

 

 

This article was last reviewed by our Support team on August 31, 2023.